Hirdetés

Keresés

Hozzászólok Aktív témák

  • aerol

    tag

    Sziasztok,

    Van köztetek olyan, aki esetleg használ Transmission-t és mondjuk költözött már át router-ről (Xiaomi Mi3 padavan-nal) raspberry pi-re transmission-nal és a pi-n docker-ből futtatja a TM-et?

    Mi a legegyszerűbb módja a költözésnek adatvesztés nélkül? Ahogy nézem a routeren 2.92 a pi-n 3.0-ás verzó van fent. Ez okozhat problémát?

    Előre is köszi a segítséget! :R

    Nokia 3310 - SonyEriccson w200i - Nokia N8 - Honor H60-L04 - Xiaomi Mi 8 /128 black

  • aerol

    tag

    Sziasztok,

    Docker-ben futtatnék PiHole-t, de valahogy nem kerek a történet. Pi-n rasbian fut desktoppal és ha vnc-n bejelentkezek és chromiumban megnyitok bármilyen lapot, azon nincs reklám, sőt még írja is, hogy ők a reklámokból élnek... :K

    A hálózatom úgy néz ki, hogy van egy Xiaomi Mi3-as routerem Padavan szoftverrel. Routeren két eszköz lóg rajta kábelen, az egyik a Pi, a másik egy pc. Wifin egy teló és egy tablet.

    Az IP-k így néznek ki:
    Router: 192.168.69.1
    PI: 192.168.69.116 statikus
    PC: 192.168.69.118
    Teló: 192.168.69.117
    Tablet: 192.168.69.34

    Docker-ben jelenleg 3 dolog fut, Portainer, Transmission és Pihole.

    Készítettem egy macvlan-t ssh-n keresztül.
    docker network create -d macvlan --subnet=192.168.69.0/24 --gateway=192.168.69.1 -o parent=eth0 pihole_net

    Portainer-ben az alábbiakat állítottam be:
    name: pihole
    image: pihole/pihole:latest

    port mapping:
    443 - 443 TCP
    53 - 53 TCP
    53 - 53 UDP
    80 - 80 TCP
    67 - 67 UDP

    advanced container setting - volumes
    container
    /etc/dnsmasq.d (bind)
    host
    /media/WDHDD01/docker/pihole/dnsmasq.d (writable)
    container
    /etc/pihole (bind)
    host
    /media/WDHDD01/docker/pihole/pihole (writable)

    Advance container settings - Network
    network: pihole_net
    hostname: pihole_docker
    mac address: ezt üresen hagytam
    ipv4: 192.168.69.200
    primary dns server: 127.0.0.1
    secondary dns server: 1.1.1.1

    Advance container settings - Environment
    name: TZ - Europe/Budapest
    name: SERVERIP - 192.168.69.200
    name: WEBPASSWORD - jelszó

    Advanced container setting - Capabilities
    Net-Admin enable

    Ezekkel a beállításokkal elindul a Pihole, be is tudok lépni.
    Pihole-ban Settings - DNS-nél
    Cloudflare pipa,
    Never forward non-FQDNs pipa,
    Never forward reverse lookups for private IP ranges pipa,
    Use DNSSEC pipa
    IP of your router: 192.168.69.1 domain név.
    Listen only on interface eth0.

    Beállítások után mindent újra indítottam, router, pi, pc. Ekkor egy ideig működik a dolog a pc-n. De aztán kb 5-10 perc múlva, mintha nem lenne semmi. Viszont ahogy az elején írtam, magán a Pi-n minden jó.
    Hol sikerült benéznem valamit? Van valamilyen ötletetek? :F

    Előre is köszi a segítséget. :R

    Nokia 3310 - SonyEriccson w200i - Nokia N8 - Honor H60-L04 - Xiaomi Mi 8 /128 black

  • aerol

    tag

    válasz stigma #446 üzenetére

    Teljesen jól van, Healthy-nek mutatja.
    Persze, beállítottam:

    DNS1: a pihole címe, 192.168.69.200
    DNS2: 1.1.1.1

    IPv6 mennyire kavarhat be? Routeren be van állítva.

    Nokia 3310 - SonyEriccson w200i - Nokia N8 - Honor H60-L04 - Xiaomi Mi 8 /128 black

  • aerol

    tag

    válasz stigma #449 üzenetére

    Nagyon úgy tűnik, hogy az IPv6 kavart be. Tegnap óta jól működik.

    haddent: vannak helyzetek, amikor seggel visszafelé csinálok dolgokat, nem direkt, csak így alakul. :DDD

    Pihole-lal meg szerintem az a helyzet, hogy egy ideje ez a legfelkapottabb ilyen megoldás, ami ezernyi oldalon jön szembe. Az olyan kis bamba júzer mint én, meg örül mint majom a f@rkának, miközben a szakik, vagy akik kicsit többet foglalkoznak ilyen dolgokkal szörnyülködnek. Mindenesetre van mit hova fejlődni. :U

    Nokia 3310 - SonyEriccson w200i - Nokia N8 - Honor H60-L04 - Xiaomi Mi 8 /128 black

  • aerol

    tag

    Sziasztok,

    Egy Raspberry 4-en (4GB) futtatok docker-t, benne pár alap dolgot, pi-hole, transmission, plex, watchtower és portainer. Pár hete kipróbáltam plex-et, egész jó, de vmiért iszonyat zabálja a Pi-t. Elindítom és mind a négy mag közel 100%-on pörög, még akkor is, ha semmit nem nézek rajta. :F
    Pár napja haddent említette meg a jellyfin-t, mint plex és emby alternatívát. Gondoltam kipróbálom. Viszont valamiért nagyon nem akar összejönni. :O

    Portainer-ben látom, hogy elindul a dolog. Viszont, amikor beírom a böngészőbe a Pi címét 192.168.69.116:8096 konkrétan azt kapom, hogy a webhely nem érhető el, A http://0.0.0.0:8096/ weboldal ideiglenesen nem érhető el, vagy véglegesen új címre költözött.

    Ellenben Transmission, ugyanezen az ip-n, csak más porton simán bejön.

    A docker-compose fájlom így néz ki:

    version: "2.1"
    services:
      jellyfin:
        image: ghcr.io/linuxserver/jellyfin
        container_name: jellyfin
        environment:
          - PUID=1000
          - PGID=1000
          - TZ=Europe/Budapest
          - UMASK_SET=022
        volumes:
          - /media/WDHDD01/docker/jellyfin/config:/config
          - /media/WDHDD01/docker/transmission/downloads/complete:/data/movies
          - /opt/vc/lib:/opt/vc/lib #optional
        ports:
          - 8096:8096
          - 8920:8920
        devices:
          - /dev/dri:/dev/dri #optional
          - /dev/vcsm:/dev/vcsm #optional
          - /dev/vchiq:/dev/vchiq #optional
          - /dev/video10:/dev/video10 #optional
          - /dev/video11:/dev/video11 #optional
          - /dev/video12:/dev/video12 #optional
        restart: unless-stopped

    Próbáltam devices nélkül, akkor se volt jó. Portainer-ben a log így néz ki:

    [s6-init] making user provided files available at /var/run/s6/etc...exited 0.
    [s6-init] ensuring user provided files have correct perms...exited 0.
    [fix-attrs.d] applying ownership & permissions fixes...
    [fix-attrs.d] done.
    [cont-init.d] executing container initialization scripts...
    [cont-init.d] 01-envfile: executing... 
    [cont-init.d] 01-envfile: exited 0.
    [cont-init.d] 10-adduser: executing...
    -------------------------------------
              _         ()
             | |  ___   _    __
             | | / __| | |  /  \ 
             | | \__ \ | | | () |
             |_| |___/ |_|  \__/
    Brought to you by linuxserver.io
    -------------------------------------
    To support the app dev(s) visit:
    Jellyfin: https://opencollective.com/jellyfin
    To support LSIO projects visit:
    https://www.linuxserver.io/donate/
    -------------------------------------
    GID/UID
    -------------------------------------
    User uid:    1000
    User gid:    1000
    -------------------------------------
    [cont-init.d] 10-adduser: exited 0.
    [cont-init.d] 30-config: executing... 
    [cont-init.d] 30-config: exited 0.
    [cont-init.d] 40-gid-video: executing... 
    [jellyfin-init] Pi Libs detected loading
    [cont-init.d] 40-gid-video: exited 0.
    [cont-init.d] 99-custom-scripts: executing... 
    [custom-init] no custom files found exiting...
    [cont-init.d] 99-custom-scripts: exited 0.
    [cont-init.d] done.
    [services.d] starting services
    [services.d] done.

    Van valamilyen ötletetek, hogy mit rontok el? A vicc az, hogy a pc-n virtualbox-ban létrehoztam egy debian-os vm-et, docker-rel jellyfin-nel és portainer-rel és ott simán megy. :Y

    Előre is köszi a segítséget :R

    Nokia 3310 - SonyEriccson w200i - Nokia N8 - Honor H60-L04 - Xiaomi Mi 8 /128 black

  • aerol

    tag

    válasz haddent #671 üzenetére

    Köszi a tippet, végül a jellyfin-es image-t használtam és most megy is viszonylag rendesen, csak a metaadatokkal van némi baj pár sorozatnál. Ha jól sejtem, fel kell építsek egy könyvtárstruktúrát és nem csak úgy ömlesztve (letöltve) kéne tárolni a filmeket. :B Asszem búcsut intek az nc-os 2000 alatti helyezésnek :DDD

    Egyébként érdekel ez a Sonarr/Radarr/Bazarr/Lidarr/Readarr cucc, bár fene se tudja, lehet sok lenne már a jóból... :U

    Nokia 3310 - SonyEriccson w200i - Nokia N8 - Honor H60-L04 - Xiaomi Mi 8 /128 black

  • aerol

    tag

    válasz g.gergo #808 üzenetére

    szia,

    azt végül megoldottam, hadden-t tanácsára inkább az ofisöl jellyfin-t használtam linuxserver helyett és az elsőre beröffent :K tegnap adtam hozzá a zene mappámat is, na itt egyelőre kerget az agybaj, hogy át kell strukturálni a mappáimat mert egyelőre nagy a káosz :Y

    Nokia 3310 - SonyEriccson w200i - Nokia N8 - Honor H60-L04 - Xiaomi Mi 8 /128 black

Hozzászólok Aktív témák

Hirdetés