Súlyos sebezhetőség a Java 7-ben

Hirdetés

Tegnap több biztonsági cég is megerősítette, hogy súlyos nulladik napi sebezhetőség található a Java Runtime Environment (JRE) 7-es verziójában, mely lehetővé teszi, hogy támadók tetszőleges kódokat futtassanak a célba vett rendszereken.

java

Mivel az Oracle csak október közepén tervezi kiadni következő frissítését, így komoly gondokat okozhat a rés, melyet a szakértők szerint, ha szűk körben is, már most is kihasználnak. Habár az első tudósítások szerint kizárólag a 7-es verzió érintett, így a korábbira való visszaváltással kellő védelem érhető el, a legújabb információk szerint ez nem teljesen biztos – a technikai részletek iránt érdeklődőknek ajánljuk a Buhera Blog összefoglalóját az exploitról.

A fertőzésre egy bevett megoldást alkalmaznak a támadók: egy weboldalba rejtik el kódjukat, mely a felhasználó tudta nélkül töltődik le a számítógépekre. Eredeti formájában a már nyilvánosságra került módszer csak windowsos gépeken működik, de a Metasploit tesztjei szerint nagyon könnyű Linuxon vagy Mac OS X-en is alkalmazni. Így a sebezhetőség az összes nagy operációs rendszert, illetve az összes böngészőt (Chrome, Firefox, Internet Explorer, Opera, Safari) érinti, amennyiben a Java plug-in telepítve van hozzájuk.

Az exploit közvetlen forrását nem ismerik, de a malware-t egy kínai gépen fedezték fel, és a szakértők úgy vélik, hogy a kártékony kódot vezérlő szerver valószínűleg Szingapúrban található.

Tökéletes megoldás nincs, mely a javítás megérkezéséig biztonságot adna, a Deep And Research által megadott sem az, így a legjobb megoldásnak szakértők szerint a Java letiltása számít.

Hirdetés

Azóta történt

Előzmények